Announcing Tapestry 5.3.5

The Tapestry Team is very proud to announce the availability of Apache Tapestry 5.3.5.

Tapestry is primarily available for download via Maven, from the Maven central repository:

Maven Dependency

You can also download the binary, source, or JavaDoc archives.

Tapestry 5.3.5 is the latest maintenance release from the stable 5.3 release branch. Full details are in the release notes; This release fixes a number of minor annoyances, an important bug in how Tapestry manipulates Java bytecode, and includes fixes for several problems related to Internet Explorer compatibility (primarily, by upgrading Tapestry's built-in copy of Prototype to version 1.7.1).

Some testers have noticed an issue with Tapestry's DateField component not operating correctly in some versions of Internet Explorer. Please test carefully before upgrading.

As usual for each Tapestry 5 release we've made great efforts to ensure an easy upgrade path; but be sure to read the upgrade notes carefully as some interfaces and methods that were deprecated in earlier major releases may have been removed: you should recompile and retest your application after upgrading your dependency. If you still have problems, use the Tapestry user mailing list to get support.