Supported Environments and Versions

Tapestry is compatible with a wide range of app servers, Java versions, and open source libraries. Not all combinations are known to work, however.

Note: blanks in the support matrix tables below do NOT indicate incompatibility. They are just documentation gaps.

If you know of any other known compatibilities or incompatibilities, please add a comment at the bottom of this page, or on the Tapestry Users mailing list mailing list.

Java & Servlet API Versions

Tapestry Version →5.8.4+5.8.1 - 5.8- -
Java JRE8-218-178-148-148-127, 816 - 81,26, 75, 65, 65, 65, 65, 6
Servlet API3.0+3.0+3.0+3.0+3.0+2.5+2.5+2.5+2.4+32.4+32.4+32.4+32.4+3

2 For using Tapestry 5.3.8 with Java 8 see Release Notes 5.3.8

3 Servlet API 2.5 requires JDK 1.5+

App Servers

Tapestry Version →5.5+ -
Apache Tomcat6+6+
Jetty 9 7-9 6-9 6-86-86-86-86-86-8
Apache TomEE
JBoss EAP4.2.34+
Wildfly/JBoss AS
Google App Engine+


These are the library versions known to work (and, in some cases, bundled with Tapestry). Unless otherwise noted, adjacent versions will often work fine as well.

Tapestry Version →5.7.3+5.5+ -
Bootstrap CSS4.3.1,

Java 9+ Dependency Deprecations

With the introduction of the Java module system in version 9, various Java EE dependencies were declared deprecated, and removed entirely in version 11.

This might lead to java.lang.NoClassDefFoundError exceptions for  javax-package classes, like missing javax.xml.bind.JAXBException for tapstry-hibernate.

Until all related libraries and frameworks add the now missing dependencies explicitly, you might have to re-add them yourself, if no other dependency is pulling them into your project.

See and for more information about the deprecation and removal of the Java EE dependencies, and how to remedy.