Supported Environments and Versions

Tapestry is compatible with a wide range of app servers, Java versions, and open source libraries. Not all combinations are known to work, however.

Note: blanks in the support matrix tables below do NOT indicate incompatibility. They are just documentation gaps.

If you know of any other known compatibilities or incompatibilities, please add a comment at the bottom of this page, or on the Tapestry Users mailing list mailing list.

Java & Servlet API Versions

Tapestry Version →5.55.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Java JRE8-127, 816 - 81,26, 75, 65, 65, 65, 65, 61.4, 5, 6
Servlet API3.0+2.5+2.5+2.5+2.4+32.4+32.4+32.4+32.4+32.2-2.3

2 For using Tapestry 5.3.8 with Java 8 see Release Notes 5.3.8

3 Servlet API 2.5 requires JDK 1.5+

App Servers

Tapestry Version →5.55.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Apache Tomcat6+6+
Jetty 9 7-9 6-9 6-86-86-86-86-86-86-7
Glassfish2.1
Apache TomEE
JBoss EAP4.2.34+
Wildfly/JBoss AS
Heroku
Google App Engine+

Libraries

These are the library versions known to work (and, in some cases, bundled with Tapestry). Unless otherwise noted, adjacent versions will often work fine as well.

Tapestry Version →5.55.4.15.45.3.85.3.75.3.3-5.3.65.3.25.3 - 5.3.15.2.15.25.15.0.165.0.105.0.85.04.1
Hibernate5.1.0.Final?-4.3.63.5.4-3.6.0-3.6.03.3.0+
JPA
Spring3.1.0
jQuery.js1.12.1
Prototype.js1.7.11.71.71.71.71.6.11.6.11.6.0.31.6.0.31.6.0.21.61.6
Scriptaculous1.91.91.91.91.91.8.21.8.21.8.21.8.0
Bootstrap CSS4.3.1, 3.3.63.3.63.0.2
Moment.js2.12.0
Less4J1.2.1-1.9
Underscore.js1.3.31.1.71.1.7