Release Upgrade FAQ

Release Upgrade FAQ

Main Article: Release Notes

Why do I get an exception about org.apache.tapestry5.internal.services.RequestPathOptimizer after upgrading to 5.2?

Although Tapestry works very hard to keep backwards compatibility between releases for public APIs, all internal APIs are subject to change. This error is commonly due to the use of the ChenilleKit library, which makes use of some internal APIs. You must also upgrade your ChenilleKit dependency when moving from Tapestry 5.1 to 5.2 or later. See the complete discussion of this from the Tapestry user mailing list.