Supported Environments and Versions

Tapestry is compatible with a pretty wide range of app servers, Java versions, and open source libraries. Not all combinations are known to work, however.

Note: blanks in the support matrix tables below do NOT indicate incompatibility. They are just documentation gaps.

If you know of any other known compatibilities or incompatibilities, please add a comment at the bottom of this page, or on the Tapestry Users mailing list mailing list.

Java & Servlet API Versions

Tapestry Version →5.55.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Java JRE1.8+1.7, 1.81.6 - 1.811.6, 1.71.5, 1.61.5, 1.61.5, 1.61.5, 1.61.5, 1.61.4-1.6
Servlet API3.0+2.5+2.5+2.5+2.4+2.4+2.4+2.4+2.4+2.2-2.3

1 For using Tapestry 5.3.8 with Java 1.8 see Release Notes 5.3.8

2 Servlet API 2.5 requires JDK 1.5+

App Servers

Tapestry Version →5.55.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Apache Tomcat6+  6+      
Jetty 9 7-9 6-9 6-86-86-86-86-86-86-7
Glassfish     2.1    
Apache TomEE          
JBoss EAP 4.2.3      4+ 
Wildfly/JBoss AS          
Heroku          
Google App Engine     +    
Amazon AWS          

Libraries

These are the library versions known to work (and, in some cases, bundled with Tapestry). Unless otherwise noted, adjacent versions will often work fine as well.

Tapestry Version →5.55.4.15.45.3.85.3.75.3.3-5.3.65.3.25.3 - 5.3.15.2.15.25.15.0.165.0.105.0.85.04.1
Hibernate  ?-4.3.6     3.5.4-3.6.0-3.6.0 3.3.0+    
JPA                
Spring      3.1.0         
jQuery.js 1.12.1              
Prototype.js  1.7.1 1.71.71.71.71.6.11.6.11.6.0.31.6.0.31.6.0.21.61.6 
Bootstrap CSS 3.3.63.0.2             
Moment.js 2.12.0              
Less4J  1.2.1-1.9             
Underscore.js     1.3.31.171.17